Choose Region

JFrog Cloud Platform outage affecting subset of customers in GCP US region

Incident Report for JFrog Cloud

Resolved

The service degradation affecting Artifactory uploads and downloads in the GCP US regions has been resolved.
JFrog Engineers are continuing to monitor the service health closely.
Posted Jun 10, 2026 - 06:20 UTC

Update

We are continuing to work on a fix for this issue.
Posted Jun 10, 2026 - 05:43 UTC

Identified

GCP (Cloud Provider) , is currently experiencing an issue with their Object Storage infrastructure, which is affecting Artifactory upload and download operations in the US regions.
JFrog engineers are actively monitoring the situation and working closely with GCP toward a resolution.
Posted Jun 10, 2026 - 05:32 UTC
This incident affected: US - East1 (S. Carolina) - GCP (Artifactory), US - Central1 (Iowa) - GCP (Artifactory), US - West1 (Oregon) - GCP (Artifactory), US - East4 (N. Virginia) - GCP (Artifactory), and US - West2(Los Angeles) - GCP (Artifactory).