Choose Region
Artifactory, Xray service Degradation for AWS USE region
Incident Report for JFrog Cloud
Resolved
This incident has been resolved.
Posted Mar 02, 2022 - 01:22 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 02, 2022 - 00:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 01, 2022 - 22:57 UTC
Investigating
We are currently investigating the issue. A subset of customers might be seeing slowness in uploads and downloads.
Posted Mar 01, 2022 - 21:56 UTC
This incident affected: US - East1 (N. Virginia) - AWS (Artifactory, Xray).