The network issue has been resolved & all the customers' services have been recovered. JFrog Engineers are continuing to monitor the service stability.
Posted May 20, 2026 - 11:01 UTC
Identified
JFrog Engineering Team is investigating a network issue which impacted a subset of customers in AWS US West region The services are being recovered
Posted May 20, 2026 - 10:35 UTC
This incident affected: US - West2 (Oregon) - AWS (Artifactory, Security - Xray, Security - JAS, Security - Curation, Security - Catalog, Security - Runtime, Distribution, Pipelines, Web UI, Webhook).