Choose Region

JFrog Cloud Platform outage affecting subset of customers in AWS US East region

Incident Report for JFrog Cloud

Resolved

The issue has been resolved. All services in the AWS US East region are fully operational.
JFrog Engineers are continuing to monitor to ensure stability.
Posted May 21, 2026 - 06:35 UTC

Investigating

We are currently investigating an infrastructure issue in the AWS US East region that may impact a limited number of customers.
Our engineering team is actively working to restore full service.
Posted May 21, 2026 - 06:04 UTC
This incident affected: US - East1 (N. Virginia) - AWS (Artifactory, Security - Xray, Security - JAS, Security - Curation, Security - Catalog, Security - Runtime, Distribution, Pipelines, Web UI, Webhook).