Choose Region
We are experiencing an issue with Google Compute Engine and Cloud Networking in us-east1
Incident Report for JFrog Cloud
Resolved
Google Cloud Networking Incident #20005 (https://status.cloud.google.com/incident/cloud-networking/20005) is now resolved.

If you have questions or feel that you may be impacted, Please contact JFrog support at https://support.jfrog.com/ and we will work with you until the issue is resolved.


Thank you for your patience.
Posted Jun 29, 2020 - 20:37 UTC
Monitoring
Our engineering team is monitoring JFrog Cloud services based on
Google Cloud Networking Incident #20005 (https://status.cloud.google.com/incident/cloud-networking/20005).

In case you are experiencing service interruptions, Please contact JFrog support at https://support.jfrog.com/
We apologize to all who are affected by the disruption.
Posted Jun 29, 2020 - 18:30 UTC
Update
By Google Compute Engine Incident #20004:
"Services in us-east1-d have been restored. Services in us-east1-c are still being restored. No ETA as of now.
The impact is due to power failure. A more detailed analysis will be available at a later time."

Since JFrog Cloud VM instances are equally spread across three zones, two-thirds of them will not be impacted.
On top of that, we are using Autoscaler and , it will notice increased traffic in other zones and adjust their number accordingly. After the faulty zone goes back to normal, the load will be rebalanced to use all three zones again.
Also, our load balancer routes request only to healthy instances. When the load balancer determines that an instance is unhealthy, it stops routing requests to that instance.
Posted Jun 29, 2020 - 16:31 UTC
Identified
We are investigating an availability issue that is impacting some JFrog Cloud Platform customers due to an issue we identified at the cloud provider resources,
more information can be found here:
https://status.cloud.google.com/incident/compute/20004
https://status.cloud.google.com/incident/cloud-networking/20005

We will provide more details within the next hour.
Posted Jun 29, 2020 - 16:14 UTC
This incident affected: US - East1 (S. Carolina) - GCP (Artifactory) and US - East1 (S. Carolina) - OSS - GCP (Artifactory).